0
$\begingroup$

I am simply trying to modulate a wav file sampled at 22.05kHz, then demodulate it. The audio output is choppy and I get errors in the console output ("volk warning, no arch found... though I've run the profiler. And aUaUaU....). I guess the issue is with matching sample rates but I've gone through the graph several times and haven't found it.

Also maybe this is related: after I add the bottom row of components (channel model and beyond) the constellation diagram for the transmit side changes to flat. Meaning, instead of a circle, it's a line (second screenshot below). What's going on?

flowgraph

enter image description here

$\endgroup$
17
  • $\begingroup$ The sampling rate of the lower LPF seems to be off by a factor of 10. $\endgroup$
    – MBaz
    Mar 26 at 20:57
  • $\begingroup$ please update to GNU Radio 3.8 or 3.9. We've greatly improved multiple blocks in your flow graph (fixed bugs in WBFM receive, for example). Anyways, are you sure you want to do a 10× interpolation on transmit? that sounds very much like overkill. then, 91× up, channel modell, then /91 down resampling makes literally no sense. Your channel has a length of 2, not 182... the plot you've done looks 100% correct, so I don't really know what you're asking us? These are real numbers, of course they are on the real axis? $\endgroup$ Mar 26 at 21:19
  • $\begingroup$ @MarcusMüller sadly installing from source gave me multiple problems, I had to rely on my package manager. Every few years I seem to try to install from source again for some new project, and every few years I run into another set of problems doing so. And I'm using the directions provided for installing from source. $\endgroup$
    – HorseHair
    Mar 26 at 21:37
  • $\begingroup$ @MarcusMüller - Putting the response to your question in a separate comment: I am trying to reach the sample rate of the radio's I plan on using after it works in this form. My target rate is 20M. So it seems you see no errors in the plot (now that I've explained the interpolation)? So the audio underflows and problems with the sound must be an issue with my system and/or gnuradio? $\endgroup$
    – HorseHair
    Mar 26 at 21:39
  • 1
    $\begingroup$ nothing wrong far as I can see, only that the high resampling rates might lead to CPU congestion $\endgroup$ Mar 26 at 21:41
0
$\begingroup$

I wasn't alone it seems. It is apparently a known issue and the solution here solved this for me as well: https://github.com/gnuradio/gnuradio/issues/1516

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.